Saturday, February 2, 2008

Branding and using a cisco router with your cable connection

So yeah the last post was an SEO aimed piece of sellout garbage...so sue me. Anyways, one thing I wanted to talk about was branding. If you look in the jargon file their is a part about the weaknesses of a hacker and my biggest weakness is my loyalty to a brand that I detest their corporate presence and love their products. No not apple. I love cisco routers and switches. In fact I own a 2611. I thought it died recently and having always known that cisco products are nearly indestructible was caught off guard....turns out it's fine, but for future reference if you leave a cisco router out in the cold for 3 days give it a few minutes to warm up before plugging it in. Ok so it takes a lot of work to get a cisco to the same point as a normal consumer grade router so I am going to make it a little easier for you by posting my cfg file. Basically all this helps it do NAT. This config will work with a cable modem setup.


!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname LonelyRouter
!
enable secret 5 $1$.3R.$UuBrRGuU9BAbBkN03EYBi/
!
ip subnet-zero
!
!
ip name-server 68.87.68.162
ip name-server 68.87.74.162
ip dhcp excluded-address 192.168.2.1
ip dhcp excluded-address 192.168.103.1
!
ip dhcp pool CLIENT
import all
network 192.168.103.0 255.255.255.0
dns-server 68.87.68.162
default-router 192.168.103.1
!
ip audit notify log
ip audit po max-events 100
!
!
!
interface Ethernet0/0
ip address dhcp
ip nat outside
no ip route-cache
no ip mroute-cache
half-duplex
no cdp enable
!
interface Ethernet0/1
ip address 192.168.103.1 255.255.255.0
ip nat inside
half-duplex
!
ip nat inside source list 102 interface Ethernet0/0 overload
ip nat inside source list 103 interface Ethernet0/0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Ethernet0/0
ip http server
ip pim bidir-enable
!
access-list 103 permit ip 192.168.103.0 0.0.0.255 any
!
line con 0
line aux 0
line vty 0 4
password set
login
!
end

Ok so some things you want to change are your ip nameserver, you probably want your own ip scheme. If you have any other questions just hit me up. Much love.

No comments: